$re = '/\/\/(.+?)\.\w+\//m';
$str = 'http://autoit.script.com
http://autoit-script.com
http://autoitscript.com
http://autoit%20script.com
http://autoit_script.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);