re = /\/\/(.+?)\.\w+\//m
str = 'http://autoit.script.com
http://autoit-script.com
http://autoitscript.com
http://autoit%20script.com
http://autoit_script.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end