using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<TopicSet.*?>)([\s\S]*?)(<\/TopicSet>)";
string substitution = @"$2";
string input = @"<TopicSet FormalName=""PARENT1"">
<Topic>
<TopicType FormalName=""Child1"" />
</Topic>
<Topic>
<TopicType FormalName=""Child2"" />
</Topic>
<Topic>
<TopicType FormalName=""Child3"" />
</Topic>
</TopicSet>
<TopicSet FormalName=""PARENT2"">
<Topic>
<TopicType FormalName=""Child1"" />
</Topic>
<Topic>
<TopicType FormalName=""Child2"" />
</Topic>
<Topic>
<TopicType FormalName=""Child3"" />
</Topic>
</TopicSet>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}