# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<TopicSet.*?>)([\s\S]*?)(<\/TopicSet>)"
test_str = ("<TopicSet FormalName=\"PARENT1\">\n"
" <Topic>\n"
" <TopicType FormalName=\"Child1\" />\n"
" </Topic>\n"
" <Topic>\n"
" <TopicType FormalName=\"Child2\" />\n"
" </Topic>\n"
" <Topic>\n"
" <TopicType FormalName=\"Child3\" />\n"
" </Topic>\n"
"</TopicSet>\n"
"<TopicSet FormalName=\"PARENT2\">\n"
" <Topic>\n"
" <TopicType FormalName=\"Child1\" />\n"
" </Topic>\n"
" <Topic>\n"
" <TopicType FormalName=\"Child2\" />\n"
" </Topic>\n"
" <Topic>\n"
" <TopicType FormalName=\"Child3\" />\n"
" </Topic>\n"
"</TopicSet>")
subst = "$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.