use strict;
my $str = 'test {{abcd dog cat}} test';
my $regex = qr/{({\w+(?: \w+)*})}/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";