re = /{({\w+(?: \w+)*})}/m
str = 'test {{abcd dog cat}} test'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result