$re = '/{({\w+(?: \w+)*})}/m';
$str = 'test {{abcd dog cat}} test';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;