# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m-s)(?:^(?=.*\bbar\b)|(?!^)\G).*?\K[ ]{2}/\t/g;t' <<< "foo: here is some sample text
bar: here is some sample text
The closest that I've gotten has been using this:
"