const regex = /(?m-s)(?:^(?=.*\bbar\b)|(?!^)\G).*?\K[ ]{2}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m-s)(?:^(?=.*\\bbar\\b)|(?!^)\\G).*?\\K[ ]{2}', 'g')
const str = `foo: here is some sample text
bar: here is some sample text
The closest that I've gotten has been using this:
`;
const subst = `\t`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);