import Foundation
let pattern = #"(?m-s)(?:^(?=.*\bbar\b)|(?!^)\G).*?\K[ ]{2}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
foo: here is some sample text
bar: here is some sample text
The closest that I've gotten has been using this:
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\t"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)