#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:https?:\/\/)?(?:www\.)?(?:[a-zA-Z0-9][-a-zA-Z0-9%_\+~#=]*\.)+[a-zA-Z][a-zA-Z0-9]{0,6}(?:/[a-zA-Z0-9_%+=~\-]+\.)*(?:#(?:[a-zA-Z][a-zA-Z0-9]+=[a-zA-Z0-9]*,)*(?:[a-zA-Z][a-zA-Z0-9]+=[a-zA-Z0-9]*))?"
Local $sString = "google.com/dreg...greg..ergtrg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")