re = /(?:https?:\/\/)?(?:www\.)?(?:[a-zA-Z0-9][-a-zA-Z0-9%_\+~#=]*\.)+[a-zA-Z][a-zA-Z0-9]{0,6}(?:\/[a-zA-Z0-9_%+=~\-]+\.)*(?:#(?:[a-zA-Z][a-zA-Z0-9]+=[a-zA-Z0-9]*,)*(?:[a-zA-Z][a-zA-Z0-9]+=[a-zA-Z0-9]*))?/m
str = 'google.com/dreg...greg..ergtrg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end