$re = '/.* \(([A-Z0-9-]+)\/([A-Z0-9-]+)\)/';
$str = 'Max Mustermann (PS-EC/ECB1-ESG23)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);