re = /.* \(([A-Z0-9-]+)\/([A-Z0-9-]+)\)/
str = 'Max Mustermann (PS-EC/ECB1-ESG23)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end