$re = '/[^\w.]/m';
$str = '....................723.103..275........*......564..*.........830........................*...../..............................232...........
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);