re = /[^\w.]/m
str = '....................723.103..275........*......564..*.........830........................*...../..............................232...........
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end