const regex = /([^'` "\n]+)\.([^ \n]+)&([^ "`'\n]+)(?!["'])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\'` "\\n]+)\\.([^ \\n]+)&([^ "`\'\\n]+)(?!["\'])', 'g')
const str = `www.google.com/mom=3&f
-H "Content-Type: google.com/cool?cool1=yes&cool2=no&cool3=no" \\\\
-H "Content-Type: google.com/cool?mom=3&f" \\\\
www.google.com/mom=3&fbom=cbom'
"www.google.com/mom=3&f"
curl -X GET \\\\
-H "User-Agent: Dalvik/2.1.0 (Linux; U; Android 10; SM-A705FN Build/QP1A.190711.020) Test/4.6.4.459" \\\\
-H "Authorization: bearer XXX" \\\\
-H "x-storefront-id: 1" \\\\
-H "x-application-id: 5" \\\\
-H "Build: 4.6.4.459" \\\\
-H "Platform: Android" \\\\
-H "Gender: M" \\\\
-H "SearchSegment: 98" \\\\
-H "OSVersion: 10" \\\\
-H "DeviceId: b147ee89" \\\\
-H "pid: bdb5748e" \\\\
-H "sid: 5096fd6e" \\\\
-H "x-features: FEATURE1_ENABLED" \\\\
-H "Accept-Language: tr-TR" \\\\
-H "Content-Type: google.com/cool?cool1=yes&cool2=no&cool3=no" \\\\
google.com/cool?cool1=yes&cool2=no&cool3=no\`
/^((?!hede).)*\$/s
^(?:(?!:hede).)*\$
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}