import Foundation
let pattern = #"([^'` "\n]+)\.([^ \n]+)&([^ "`'\n]+)(?!["'])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
www.google.com/mom=3&f
-H "Content-Type: google.com/cool?cool1=yes&cool2=no&cool3=no" \\
-H "Content-Type: google.com/cool?mom=3&f" \\
www.google.com/mom=3&fbom=cbom'
"www.google.com/mom=3&f"
curl -X GET \\
-H "User-Agent: Dalvik/2.1.0 (Linux; U; Android 10; SM-A705FN Build/QP1A.190711.020) Test/4.6.4.459" \\
-H "Authorization: bearer XXX" \\
-H "x-storefront-id: 1" \\
-H "x-application-id: 5" \\
-H "Build: 4.6.4.459" \\
-H "Platform: Android" \\
-H "Gender: M" \\
-H "SearchSegment: 98" \\
-H "OSVersion: 10" \\
-H "DeviceId: b147ee89" \\
-H "pid: bdb5748e" \\
-H "sid: 5096fd6e" \\
-H "x-features: FEATURE1_ENABLED" \\
-H "Accept-Language: tr-TR" \\
-H "Content-Type: google.com/cool?cool1=yes&cool2=no&cool3=no" \\
google.com/cool?cool1=yes&cool2=no&cool3=no`
/^((?!hede).)*$/s
^(?:(?!:hede).)*$
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)