using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(1[0-2]|0?[1-9]):[0-5][0-9] (AM|PM)$";
string input = @"11:45 PM
11:45 MP
11:4 PM
1:45 AM
11:45:AM
:45 AM
// You can show origina post on albertcolom.com/blog";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}