$re = '/^(1[0-2]|0?[1-9]):[0-5][0-9] (AM|PM)$/m';
$str = '11:45 PM
11:45 MP
11:4 PM
1:45 AM
11:45:AM
:45 AM
// You can show origina post on albertcolom.com/blog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);