use strict;
my $str = '11:45 PM
11:45 MP
11:4 PM
1:45 AM
11:45:AM
:45 AM
// You can show origina post on albertcolom.com/blog';
my $regex = qr/^(1[0-2]|0?[1-9]):[0-5][0-9] (AM|PM)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}