using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/([^/]+)/([^/]+?((?<=_)X\d|$).*)";
string input = @"/l/_ _X3test
/l/_ X3test
/l/_ _Xtest
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}