re = /^\/([^\/]+)\/([^\/]+?((?<=_)X\d|$).*)/m
str = '/l/_ _X3test
/l/_ X3test
/l/_ _Xtest
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end