$re = '/^/([^/]+)/([^/]+?((?<=_)X\d|$).*)/m';
$str = '/l/_ _X3test
/l/_ X3test
/l/_ _Xtest
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);