#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(([a-zA-Z])\2+)\b|([a-zA-Z])\3+"
Local $sString = "aaa" & @CRLF & _
"aa" & @CRLF & _
"a" & @CRLF & _
"broom" & @CRLF & _
"school" & @CRLF & _
"boo" & @CRLF & _
"gool" & @CRLF & _
"ooow"
Local $sSubst = "\1\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)