import Foundation
let pattern = #"\b(([a-zA-Z])\2+)\b|([a-zA-Z])\3+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
aaa
aa
a
broom
school
boo
gool
ooow
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)