const regex = new RegExp('\\b(([a-zA-Z])\\2+)\\b|([a-zA-Z])\\3+', 'gm')
const str = `aaa
aa
a
broom
school
boo
gool
ooow`;
const subst = `\1\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);