#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=cn=)[\w\s]+(?=\\?(?:ou=)?[\w\s]*$)"
Local $sString = "ou=company\ou=country\ou=site\cn=office\cn=name\ou=pet" & @CRLF & _
"ou=company\ou=country\ou=site\cn=office\cn=name\"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")