re = /(?m)(?<=cn=)[\w\s]+(?=\\?(?:ou=)?[\w\s]*$)/
str = 'ou=company\\ou=country\\ou=site\\cn=office\\cn=name\\ou=pet
ou=company\\ou=country\\ou=site\\cn=office\\cn=name\\'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end