$re = '/(?m)(?<=cn=)[\w\s]+(?=\\\\?(?:ou=)?[\w\s]*$)/';
$str = 'ou=company\\ou=country\\ou=site\\cn=office\\cn=name\\ou=pet
ou=company\\ou=country\\ou=site\\cn=office\\cn=name\\';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);