re = /\p{L}+/
str = 'Aktivitäten und Ausflugsziele in der Nähe von keyword.
Äpfel und Straßen; bä'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end