package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-z]*[Aa][A-z]*[Rr][A-z]*|[A-z]*[Rr][A-z]*[Aa][A-z]*`)
var str = `Maria xxx Paul xxx Taylor xxx Henry xxx Ray xxx`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}