re = /[A-z]*[Aa][A-z]*[Rr][A-z]*|[A-z]*[Rr][A-z]*[Aa][A-z]*/
str = 'Maria xxx Paul xxx Taylor xxx Henry xxx Ray xxx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end