package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^:-][^:.]*\.\s*([^:]+)`)
var str = `My substring1. My substring2: My substring3: My substring4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}