re = /^[^:-][^:.]*\.\s*([^:]+)/m
str = 'My substring1. My substring2: My substring3: My substring4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end