$re = '/^[^:-][^:.]*\.\s*([^:]+)/m';
$str = 'My substring1. My substring2: My substring3: My substring4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);