re = /<span class="booking-id-value">(.+)<\/span>/
str = 'foo
<span class="booking-id-value">U166097</span>
bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end