#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+(?:\.\w+)*\.(?:testnet|near)$"
Local $sString = "example.testnet" & @CRLF & _
"sub.ex.testnet" & @CRLF & _
"something.testnet" & @CRLF & _
"shouldnotendwithperiod.testnet." & @CRLF & _
"example.near" & @CRLF & _
"space should fail.testnet" & @CRLF & _
"touchingDotsShouldfail..testnet"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")