$re = '/^\w+(?:\.\w+)*\.(?:testnet|near)$/m';
$str = 'example.testnet
sub.ex.testnet
something.testnet
shouldnotendwithperiod.testnet.
example.near
space should fail.testnet
touchingDotsShouldfail..testnet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);