package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+(?:\.\w+)*\.(?:testnet|near)$`)
var str = `example.testnet
sub.ex.testnet
something.testnet
shouldnotendwithperiod.testnet.
example.near
space should fail.testnet
touchingDotsShouldfail..testnet`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}