// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\((.*?)\))").unwrap();
let string = "Chats (Felis catus)
Chiens (Canis lupus familiaris)
Chevaux (Equus ferus caballus)
Moutons (Ovis aries)
Bovins (Bos taurus taurus)
Porcs (Susscrofa domestica)
Chèvres (Capra aegagrus hircus)
Les lapins (Oryctolagus cuniculus)
Les canards (Anas platyrhyncos domesticus)
Les dindons (Meleagris gallopavo gallopavo)
Ânes (Equus asinus)
Mules (Equus asinus x Equus caballus)
Chien
Chat
Furet
Cheval
âne
vache
lama
mule
Porc
Cochon d'Inde
Rat domestique
Hamster doré
Souris domestique
gerbille de Mongolie
Lapin domestique
Canard colvert
Poule
paon
Pigeon
tourterelle
colombe
Canari
Perruche
Poisson rouge
Carpe koï
axolotl
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}