import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b([A-Z]{2})[-\\s](20[0-9]{2}|2100)-(0?[1-9]|1[0-2])-(\\d{6})(?!\\d)";
final String string = "any text CA-2019-6-000000 any text \n"
+ "any text KA 2019-2-929029\n"
+ "KA-2019-11-929029";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}