const regex = /\b([A-Z]{2})[-\s](20[0-9]{2}|2100)-(0?[1-9]|1[0-2])-(\d{6})(?!\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([A-Z]{2})[-\\s](20[0-9]{2}|2100)-(0?[1-9]|1[0-2])-(\\d{6})(?!\\d)', 'gm')
const str = `any text CA-2019-6-000000 any text
any text KA 2019-2-929029
KA-2019-11-929029`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}