import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\s=]+)\\h+=\\h+(.*(?:\\R(?![^\\s=]+\\h+=\\h+).*)*)$";
final String string = "groupid = foo\n"
+ "location = westus\n"
+ "randomkey = fbae3700c34cb06c\n"
+ "resourcename = example4-resourcegroup\n"
+ "tls_private_key = -----BEGIN RSA PRIVATE KEY-----\n"
+ "//stuff\n"
+ "-----END RSA PRIVATE KEY-----\n\n"
+ "foo = 123\n"
+ "faa = 223";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}