import re
regex = re.compile(r"^([^\s=]+)\h+=\h+(.*(?:\R(?![^\s=]+\h+=\h+).*)*)$", flags=re.MULTILINE)
test_str = ("groupid = foo\n"
"location = westus\n"
"randomkey = fbae3700c34cb06c\n"
"resourcename = example4-resourcegroup\n"
"tls_private_key = -----BEGIN RSA PRIVATE KEY-----\n"
"//stuff\n"
"-----END RSA PRIVATE KEY-----\n\n"
"foo = 123\n"
"faa = 223")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")