package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)Vertel( me)? een (grap|mop)|(zeg|vertel)( me)? iets (grappigs|leuks)|tap een mop|maak een grap`)
var str = `tap een mop
maak een grap
vertel een grap
vertel me een grap
vertel een mop
vertel me een mop
zeg iets grappigs
zeg me iets grappigs
vertel iets grappigs
vertel me iets grappigs
zeg iets leuks
zeg me iets leuks
vertel iets leuks
vertel me iets leuks
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}