import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Vertel( me)? een (grap|mop)|(zeg|vertel)( me)? iets (grappigs|leuks)|tap een mop|maak een grap";
final String string = "tap een mop\n"
+ "maak een grap\n"
+ "vertel een grap\n"
+ "vertel me een grap\n"
+ "vertel een mop\n"
+ "vertel me een mop\n"
+ "zeg iets grappigs\n"
+ "zeg me iets grappigs\n"
+ "vertel iets grappigs\n"
+ "vertel me iets grappigs\n"
+ "zeg iets leuks\n"
+ "zeg me iets leuks\n"
+ "vertel iets leuks\n"
+ "vertel me iets leuks\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}