package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{1,2}:\d{1,2})|(\d{1,2}\s+horas{0,1})|(\d{1,2}h ?\d{0,2})`)
var str = `8:00
8 horas
8 hora
8h
8h30 (8h 30)
8h30min (8h 30 min)
8h30minutos (8h 30 minutos)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}