const regex = new RegExp('(\\d{1,2}:\\d{1,2})|(\\d{1,2}\\s+horas{0,1})|(\\d{1,2}h ?\\d{0,2})', 'g')
const str = `8:00
8 horas
8 hora
8h
8h30 (8h 30)
8h30min (8h 30 min)
8h30minutos (8h 30 minutos)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}