$re = '/(\d{1,2}:\d{1,2})|(\d{1,2}\s+horas{0,1})|(\d{1,2}h ?\d{0,2})/';
$str = '8:00
8 horas
8 hora
8h
8h30 (8h 30)
8h30min (8h 30 min)
8h30minutos (8h 30 minutos)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);